Server doesn't start anymore

Discussion in 'OpenLiteSpeed Bug Reports' started by Francesco Pepe, Feb 15, 2018.

  1. Francesco Pepe

    Francesco Pepe New Member

    After an update my server doesn't start anymore I got this error:

    Code:
    LSWS does not restart properly, check port 7080
    check port 7080 after kill all litespeed processes
    Thu Feb 15 16:06:55 UTC 2018
    start, LSWS running: 0
    LSWS does not restart properly, check port 7080
    check port 7080 after kill all litespeed processes 
     
  2. Francesco Pepe

    Francesco Pepe New Member

    If I try to start from command line:

    Code:
     
    /usr/local/lsws/bin/lswsctrl start
    /usr/local/lsws/bin/lswsctrl: 17: /usr/local/lsws/bin/lswsctrl: source: not found
    [OK] litespeed: pid=3233.
    litespeed: no process found
    [OK] litespeed: pid=3273.
    
     
  3. Pong

    Pong Administrator

    Which version? Which command did you run?
     
  4. Francesco Pepe

    Francesco Pepe New Member

    I've done a simply

    Code:
    apt-get update
    This has installed version 1.4.29+5-xenial
    After this I've tried to go to my site but got error.

    On log file I see

    Code:
    LSWS does not restart properly, check port 7080
    check port 7080 after kill all litespeed processes
    Thu Feb 15 16:06:55 UTC 2018
    start, LSWS running: 0
    LSWS does not restart properly, check port 7080
    check port 7080 after kill all litespeed processes 
    So I tried to start openlitespeed with

    Code:
    /usr/local/lsws/bin/lswsctrl start
    
    but I got this message in console:

    Code:
    /usr/local/lsws/bin/lswsctrl: 17: /usr/local/lsws/bin/lswsctrl: source: not found
    [OK] litespeed: pid=3233.
    litespeed: no process found
    [OK] litespeed: pid=3273.
     
  5. Tishu

    Tishu Member

    hello,

    Can you send me temp rood login.
     
  6. Tishu

    Tishu Member

    We manage to resolve the issue. The cache module (cache.so) was not updated. In this case you can download Openlitespeed and configure it in different directory. After that just copy the cache.so (from lsws/modules).
     

Share This Page