Openlitespeed 1.4.17 - Problem with CSS and/or static pages?

Discussion in 'Linux Support: RHEL, CentOS, SUSE etc' started by Fresh, May 4, 2016.

  1. Fresh

    Fresh New Member

    It worked fine for about month, but after upgrade to 1.4.17 strange things started to happen. I'm not sure when it started (maybe in 1.4.16) because in Firefox it's OK and I rarely use other browsers.

    Check out page: www.duettoshop.pl, it's static template webpage
    • In Google Chrome: It's displayed but without CSS
    • In Mozilla FIrefox: It's displayed fine
    • In Internet Explorer: It doesn't display. It wants to download file without extension which is index.html file

    There are no errors in Litespeed. Here is my access log for one display of main page:
    Code:
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/etline-font.css HTTP/1.1" 200 1686 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/blog-img-02.jpg HTTP/1.1" 200 240848 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET / HTTP/1.1" 200 4326 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/normalize.min.css HTTP/1.1" 200 994 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/bootstrap.min.css HTTP/1.1" 200 18711 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/jquery.fancybox.css HTTP/1.1" 200 1429 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/flexslider.css HTTP/1.1" 200 1566 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/styles.css HTTP/1.1" 200 5579 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /css/queries.css HTTP/1.1" 200 1401 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /bower_components/animate.css/animate.min.css HTTP/1.1" 200 3852 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /js/vendor/modernizr-2.8.3-respond-1.4.2.min.js HTTP/1.1" 200 8179 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /bower_components/retina.js/dist/retina.js HTTP/1.1" 200 1743 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /js/jquery.fancybox.pack.js HTTP/1.1" 200 8634 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /js/vendor/bootstrap.min.js HTTP/1.1" 200 9441 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /js/scripts.js HTTP/1.1" 200 799 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /js/jquery.flexslider-min.js HTTP/1.1" 200 6361 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /bower_components/classie/classie.js HTTP/1.1" 200 742 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /bower_components/jquery-waypoints/lib/jquery.waypoints.min.js HTTP/1.1" 200 2671 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/sedna-logo.png HTTP/1.1" 200 1338 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/devices.png HTTP/1.1" 200 91803 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/macbook-pro.png HTTP/1.1" 200 61386 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/sketch-logo.png HTTP/1.1" 200 30747 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/blog-img-01.jpg HTTP/1.1" 200 114034 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/blog-img-03.jpg HTTP/1.1" 200 177699 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/avatar.jpg HTTP/1.1" 200 5876 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/mani.jpg HTTP/1.1" 200 13253 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:41 +0200] "GET /img/130.jpg HTTP/1.1" 200 6267 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:42 +0200] "GET /favicon-16x16.png HTTP/1.1" 200 257 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    192.168.1.2 - - [04/May/2016:10:05:42 +0200] "GET /favicon-32x32.png HTTP/1.1" 200 434 "http://www.duettoshop.pl/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36"
    
    
    It looks fine. All codes 200, also for CSS

    What is happenning?

    The same is for dynamic pages. PHP works fine, but in Chrome it displays without CSS, Firefox fine, Internet Explorer wants to download file
     
  2. lsfoo

    lsfoo Administrator

    Hi Fresh,

    We got other reports of this issue as well. Could you try reinstalling 1.4.17? The original release had this problem, but it was later fixed and re-uploaded.

    If the problem still exists, turn on debug logging and try accessing a page and send us the debug log so we could check it out.

    Cheers,
    Kevin
     
  3. Fresh

    Fresh New Member

    Yes, I reinstalled OpenLitespeed on Centos 7 with
    Code:
    yum reinstall openlitespeed14
    and problem was fixed
     
    lsfoo likes this.
  4. lsfoo

    lsfoo Administrator

    Good to hear!

    Let us know if you run into any more problems!
     

Share This Page