how to solve...

Discussion in 'Linux Support: RHEL, CentOS, SUSE etc' started by Seyed Ali Roshan, Feb 12, 2016.

  1. hi,
    i think my pagespeed mode is not working and when i checked the log files i saw these:
    2016-02-12 05:52:44.364 WARN [modpagespeed] "on" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "FileCachePath" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "RewriteLevel" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    2016-02-12 05:52:44.364 WARN [modpagespeed] "EnableFilters" cannot be set at this scope.
    what do i have to do?
     
  2. lsfoo

    lsfoo Administrator

    Hi Seyed,

    The mod_pagespeed developer is not available currently. I will point him to this post on Monday.

    That said, after poking around the code, I believe what is happening is that those options are not allowed to be set at the scope where you set it. For example, if you tried to set those options at Context level, but it is supposed to be set at VHost level only, it will complain.

    Hope this helps,
    Kevin
     
  3. i put them in VH level too.
    But i m not exactly sure that it's working or not
    if you tell him(modpagespeed) i will be so grateful
     
    Last edited: Feb 13, 2016
  4. David

    David Guest

    Kevin said is correct.
    Even if a filter can be set in VHost level, it still will WARN when you set to context level, but this won't cause error.
     

Share This Page