How to set up suEXEC?

Discussion in 'Linux Support: Debian, Ubuntu, SolusOS etc' started by tyteen4a03, Mar 16, 2015.

  1. tyteen4a03

    tyteen4a03 Guest

    I'm trying to set up suEXEC and have inputted the user and group in External Scripts of my virtual hosts, but PHP still says the file is being run by the server user, which causes the script to be unable to write to the document root.

    How do I fix this?
     
  2. lsmichael

    lsmichael Active Member

    Howdy @tyteen4a03

    Sorry if this is confusing. I believe these may be holdovers from Enterprise settings. I'm not quite sure what they do on OpenLiteSpeed. For setting up suEXEC, though, you need to set the VHost Security > ExtApp Set UID Mode setting. This should enable suEXEC for this vhost.

    Cheers,

    Michael
     

Share This Page