How to run php in user level?

Discussion in 'OpenLiteSpeed Suggestions and Requests' started by wireboot, Aug 29, 2015.

  1. wireboot

    wireboot New Member

    Hello
    I installed just openlitespeed. I configured at the beginning of the server and added the first vhost.
    In it, I added External App (App LSAPI), and the Script Handler added subfix control php on External App.

    The external app added:
    User suEXEC wireboot
    suEXEC Group wireboot

    while you save the changes, graceful restart, and even /etc/init.d/lsws restart, all the time I can see that the processes are run under the nobody

    root @ Bartlomiej: ~ # ps aux | grep lsphp
    Nobody 6430 0.0 0.5 155 804 21284? S 10:56 0:00 lsphp
    Nobody 6617 0.0 0.5 155 804 21268? S 11:00 0:00 lsphp

    So how should it change? Is there a guide adapted to my question?
     
  2. lsfoo

    lsfoo Administrator

    Hi wireboot,

    Could you enable debug logging and check to see if there are any configuration error messages? If you'd rather, we can also look to see if there's anything wrong.

    If you'd rather not post the log here, you can email it to me at kfwu at litespeedtech dot com.

    Cheers,
    Kevin
     
  3. Pothi Kalimuthu

    Pothi Kalimuthu New Member

    Has this been considered for fixing?

    I have the same error on Ubuntu 16.04, OpenLiteSpeed 1.4.16 and PHP 7.0.5.
     
  4. lsfoo

    lsfoo Administrator

    Hi Pothi,

    As requested of wireboot, could you enable debug logging and check your error log to see if there's any error messages during configuration? You may also email me to look at the log if you'd like.

    Cheers,
    Kevin
     
  5. lsfoo

    lsfoo Administrator

    Is the server running as root?

    If it is not, that might be the reason why it's not working. A non-root user may not be allowed to change users.
     
  6. fidojones

    fidojones New Member

    Hi lsfoo

    I have the same problem. I installed opelitespeed 1.4.21 in debian and suexec doesn't work. I installed litespeed standard, and I configure the virtual host with the same configuration, and works perfect. I don't see any error in debug.log
     
  7. fidojones

    fidojones New Member

    I detected that doesn't work if you add de suexec user in the lsphp at server level (in litespeed standard mode it works). I you defined the suexec user in a external app at vhost level. But should work as litespeed standard, I supposed....
     
  8. lsfoo

    lsfoo Administrator

    Hi fidojones,

    Could you pm me the configurations you used? We'll test it out in our lab to see if it works for us.

    Kevin
     
  9. fidojones

    fidojones New Member

    Dear kevin:

    I sent you some data to test the problem by conversation.
     
  10. lsfoo

    lsfoo Administrator

    Hi fidojones,

    The bug is fixed. Do you feel comfortable installing openlitespeed via source? If so, it is updated on our GitHub. Not sure when it will be available on package managers yet.
     
  11. fidojones

    fidojones New Member

    Yeah tested it works fine now, really thanks :D
     
  12. lsfoo

    lsfoo Administrator

    Awesome! Let us know if there's anything else not working quite right :)
     

Share This Page