Gzip not working last version OLS 1.4.27

Discussion in 'OpenLiteSpeed Bug Reports' started by fidojones, Nov 6, 2017.

  1. fidojones

    fidojones New Member

  2. lswave

    lswave Member

  3. fidojones

    fidojones New Member

    Ok, but : Enable Dynamic Compression Yes

    Why only static files are compressed, why dynamic content it's not compressed?
     
  4. lswave

    lswave Member

    can you try a phpinfo page, to see if it's compressed ?

    also another simple hello.php page, just print some characters, to ensure its length > 300 bytes, to see if it's compressed.
     
  5. fidojones

    fidojones New Member

    Here is a test with a phpinfo:

    The gzip compression is enabled in general settings and in virtualhost: enableGzip 1

    https://checkgzipcompression.com/?url=http://www.baifox.org/testinfo.php

    By the way if for example I activate the Litespeed Cache plugin in wordpress and LSCACHE is activate in server gzip WORKS:

    https://checkgzipcompression.com/?url=http://www.neeo.es

    1. X-Litespeed-Cache:
      hit
    2. X-Litespeed-Cache-Control:
      public,max-age=604800
    3. X-Litespeed-Tag:
      3421_URL.6666cd76f96956469e7be39d750cc7d9,3421_F,3421_Po.32013,3421_PGS,3421_
     
  6. David

    David New Member

    I just fixed this bug in the latest version 1.4.28. Can you try this version?
    And for the GitHub last commit, I fixed another bug of duplicate response headers, so if you want to try 1.4.28, you may want to download the code from GitHub.
    Thanks for your feedback.
     
  7. fidojones

    fidojones New Member

    Yes it works fine in 1.4.28. I upgrade it some days ago and the problem disappear.
     
  8. David

    David New Member

    Thank you for letting me known.
    Nice.
     

Share This Page