Graceful restart in webadmin console problem.

Discussion in 'General OpenLiteSpeed Discussion' started by ckissi, Mar 26, 2017.

  1. ckissi

    ckissi New Member

    Hi,

    I've created new virtual host using a template, it says I have to make a graceful restart. If I do it from web admin it doesn't run the virtual host. I have to go to command line and run this command:

    /usr/local/lsws/bin/lswsctrl restart ... then it works

    Why the restart from web admin doesn't start the virtual host?
     
  2. lsfoo

    lsfoo Administrator

    Hi @ckissi

    Apologies here as well for the late reply. Are you still experiencing this issue?

    Cheers,
    Kevin
     
  3. ckissi

    ckissi New Member

    Yes, it's still there, I have to restart lsws from command line to apply changes
     
  4. lsfoo

    lsfoo Administrator

    OK, thanks for the quick reply. If you don't mind me asking, what permissions and ownership does your configuration file have?

    Looking for the RWX values as well as the owner:group.
     
  5. ckissi

    ckissi New Member

    -rw-r--r-- 1 lsadm lsadm 1752 Mar 28 00:37 vhconf.conf

    This is the configuration file I've been working on when it happened, But I'm experiencing this issue again and again when I'm doing changes in the admin area, e.g. when I was adding SSL certificates to webamin (7080) listener.
     
  6. lsfoo

    lsfoo Administrator

    When you restart via web admin, could you check the error log? If the timestamp looks like the server was restarted, check the last dated log (it will look like error.log.2017_04_04.01). At the bottom of the file, you should see a message similar to:

    Code:
    2017-04-04 08:32:27.806 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 35159 !
    2017-04-04 08:32:27.906 [NOTICE] [AutoRestarter] child process with pid=35159 exited with status=0!
    2017-04-04 08:32:27.906 [NOTICE] [PID:35137] Server Stopped!
    
    With the timestamp matching the time you restarted the server. Do you see this?
     
  7. ckissi

    ckissi New Member

    No change in the error log at all until I restart from the command line. Seems like it does nothing from admin interface when I invoke restart.
     
  8. lsfoo

    lsfoo Administrator

    If you are accessing the web admin using a domain (as opposed to IP), is it possible that it's sending the request to the wrong server?
     
  9. lsfoo

    lsfoo Administrator

    One thing to try is deleting all the admin.sock.* files in SERVER_ROOT/admin/tmp/ and restarting the server via command line to see if it makes it work afterwards.
     
  10. ckissi

    ckissi New Member

    This is strange, it doesn't work in chrome (all extensions disabled just for sure), but it works in opera neon which is also the chromium browser
     
  11. ckissi

    ckissi New Member

    Wow ! It works now. I've deleted all cookies and it started to work.
     
    lsfoo likes this.

Share This Page