Few Errors

Discussion in 'General OpenLiteSpeed Discussion' started by stdio, Apr 4, 2017.

  1. stdio

    stdio New Member

    Hi again,

    I am running OLS as user www and group www and I am getting this error/notice:

    2017-04-04 08:35:26.346 [NOTICE] [XX.XX.XX.XX:55474:HTTP2-53] [STDERR] PHP Warning: file_get_contents(/tmp/lshttpd/.status): failed to open stream: Permission denied in /usr/local/lsws/admin/html.open/lib/SInfo.php on line 180

    Permissions under /tmp/lshttpd:


    Code:
    # ls -al /tmp/lshttpd/
    total 44
    drwxrwxrwx  3 www  www  4096 Apr  3 20:13 .
    drwxrwxrwt 10 root root 4096 Apr  4 08:41 ..
    lrwxrwxrwx  1 www  www    33 Mar 25 01:05 .rtreport -> /dev/shm/lshttpd/status/.rtreport
    lrwxrwxrwx  1 www  www    35 Mar 25 01:05 .rtreport.2 -> /dev/shm/lshttpd/status/.rtreport.2
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.3
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.4
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.5
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.6
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.7
    -rw-r--r--  1 www  www   444 Apr  4 08:41 .rtreport.8
    -rw-------  1 www  www   240 Apr  4 08:35 .status
    -rw-r--r--  1 www  www     6 Apr  3 20:20 lshttpd.pid
    drwx------ 24 www  www  4096 Apr  3 13:52 swap
    
    Does .status require other permissions than I currently have?

    The second error I'm getting after restarting lsws is this:
    Code:
    2017-04-04 08:43:35.855    ERROR    [config:server:vhosts:vhost:mydomain.com:epsr:lsphp7] missing <path>
    Not sure why I'm getting this. PHP is working well.

    Also, in the dashboard both listeners (443 and 80) show up as "Not running" although my site is working. Is this because lsws is unable to read the /tmp/lshttpd/.status file?

    Any help is appreciated!
     
  2. lsfoo

    lsfoo Administrator

    First thing you could try is just simply deleting the .status file and restarting the server.

    When you say
    , do you mean that OLS is installed in a different directory, and you are the www user when you start OLS?

    If NOT, my .status file permissions are the following (installed in /usr/local/olsws/, started as root):
    Code:
    -rw-r--r--  1 root   nogroup  174 Apr  3 17:30 .status
    
     
  3. stdio

    stdio New Member

    I wanted to say that OLS is running as user www. I apologize. English is not my primary language.

    Deleting the file did the trick! The file ownership is now root:www. :)

    And for my final issue:
    Code:
    [config:server:vhosts:vhost:mydomain.com:epsr:lsphp7] missing <path>
    Any idea what could be causing this missing path?

    Thank you so much for helping!
     
  4. lsfoo

    lsfoo Administrator

    Not a problem!

    Could you paste your external app and script handler settings?
     
  5. stdio

    stdio New Member

  6. lsfoo

    lsfoo Administrator

    The log message is from a vhost config. Your screenshot is of a server config. Do you have a vhost external app set up? If you're not going to use it, there's no need to set it up. However, if you do intend to use it, it looks like the 'command' option is emtpy.
     
  7. stdio

    stdio New Member

    I can't believe this. I've set up OLS many times before and things always worked well. You were right! The command option was empty. :whistle:

    Thank you so much for your time!
     
  8. lsfoo

    lsfoo Administrator

    Not a problem! Let us know if you run into any more issues.

    Cheers,
    Kevin
     

Share This Page