Error in compiling (Debian 9)

Discussion in 'OpenLiteSpeed Bug Reports' started by slowaways, Aug 18, 2017.

Tags:
  1. slowaways

    slowaways New Member

  2. lsfoo

    lsfoo Administrator

    Hi @slowaways

    Can you confirm taht you have the following packages installed?

    build-essential libpcre3-dev libexpat1-dev libssl-dev libgeoip-dev zlib1g-dev curl

    Cheers,
    Kevin
     
  3. slowaways

    slowaways New Member

    No! Oh, sorry!!! I missing some of dependencies.

    Code:
    [ERROR] It is not allowed to run LiteSpeed web server on behalf of a privileged user/group, user id must not be less than 50 and group id must not be less than 10.UID of user 'root' is 0, GID of group 'root' is 0. Please fix above problem first!
    Help me about this?
     
    Last edited: Aug 21, 2017
  4. lsfoo

    lsfoo Administrator

    That message is because you are trying to run OLS as root.

    Please try changing to running as nobody:nobody or nobody:nogroup
     
  5. slowaways

    slowaways New Member

    Where do I find the settings to change the user and group?
     
  6. lskagan

    lskagan Administrator

    Under /usr/local/lsws/conf/httpd_config.conf you should see user and group settings. You will want to change both of these to either nobody or nogroup.
     
  7. slowaways

    slowaways New Member

    Thank you!
     

Share This Page