Could not chown to lsadm:{PHP_USERGROUP}

Discussion in 'OpenLiteSpeed Bug Reports' started by idawgik, Feb 2, 2015.

  1. idawgik

    idawgik Guest

    Hello,

    I'm attempting to compile PHP 5.5.21 on a CentOS 7 box using OpenLitespeed 1.4.4.

    At the end of the compliation process, it errors out with the following error:

    **ERROR** Could not chown to lsadm:{PHP_USERGROUP} for direcotry /usr/local/lsws/phpbuild/php-5.5.21

    I've never seen this error on other servers before and couldn't find anything searching around.
     
  2. lsmichael

    lsmichael Active Member

  3. Tracy Perry

    Tracy Perry Active Member

    Debian Wheezy VPS... and makes it rather hard to install for ya'll to test out the other problem I was having.

    Code:
    **MAIN_STATUS** retrieved from /usr/local/lsws/phpbuild/buildphp_1423885569.7.progress
    Start building PHP 5.6.5 with LSAPI
    Configuring PHP build (2-3 minutes)
    Compiling PHP (5-10 minutes)
    Installing PHP
    copy compiled php binary to litespeed directory
    **ERROR** Could not chown to lsadm:{PHP_USERGROUP} for direcotry /usr/local/lsws/phpbuild/php-5.6.5
    Code:
    Installing PEAR environment:      /usr/local/lsws/lsphp5/lib/php/
    [PEAR] Archive_Tar    - already installed: 1.3.12
    [PEAR] Console_Getopt - already installed: 1.3.1
    [PEAR] Structures_Graph- already installed: 1.0.4
    [PEAR] XML_Util       - already installed: 1.2.3
    [PEAR] PEAR           - already installed: 1.9.5
    Wrote PEAR system config file at: /usr/local/lsws/lsphp5/etc/pear.conf
    You may want to add: /usr/local/lsws/lsphp5/lib/php to your php.ini include_path
    /usr/local/lsws/phpbuild/php-5.6.5/build/shtool install -c ext/phar/phar.phar /usr/local/lsws/lsphp5/bin
    ln -s -f /usr/local/lsws/lsphp5/bin/phar.phar /usr/local/lsws/lsphp5/bin/phar
    Installing PDO headers:          /usr/local/lsws/lsphp5/include/php/ext/pdo/
    copy compiled php binary to litespeed directory
    cd /usr/local/lsws//fcgi-bin
    ln -sf lsphp-5.6.5 lsphp5
    chown: invalid group: `lsadm:{PHP_USERGROUP}'
    **ERROR** Could not chown to lsadm:{PHP_USERGROUP} for direcotry /usr/local/lsws/phpbuild/php-5.6.5
     
  4. lsmichael

    lsmichael Active Member

    Howdy Tracy,

    Hmmm... Yes, that is an issue. It's fixed in 1.3.7, but apparently not in 1.4.4 yet. The fix will be in 1.4.5, but obviously we don't want to wait for that (if we don't have to). We've just updated the GitHub repository with the fix just now. Could you get the source from there?

    m
     
  5. Tracy Perry

    Tracy Perry Active Member

    It will be a day or so before I can. Been rather busy with a EMR conversion at a local physicians office.
     
  6. lsmichael

    lsmichael Active Member

    That's cool. It looks like we're actually going to push out 1.4.5 sometime this week. We found a HTTP/2 bug (that was somewhat related to the SPDY image upload bug reported elsewhere) and we want to make sure the HTTP/2 support is as complete as possible. So, if you want, you can just wait for 1.4.5 instead of updating from GitHub.

    m
     

Share This Page